NFL links are being redirected (for many/most but not all)

Discussion in 'Announcements and Support' started by daves, Apr 9, 2020.

  1. daves

    daves Keepin' it real! Contributor

    Posts:
    2,055
    Likes Received:
    2,279
    Joined:
    Nov 2, 2003
    Location:
    Orange County, CA
    Strange - they (usually!) work for me, and this one does.

    ...dave
     
  2. cardncubfan

    cardncubfan H

    Age:
    57
    Posts:
    7,819
    Likes Received:
    3,077
    Joined:
    Aug 7, 2008
    Location:
    Chandler
    Do you use Chrome? I do & the links redirect to Gamepass & videos on the Cards site won't play on it. I have to use Mozilla. Not sure why.
     
  3. daves

    daves Keepin' it real! Contributor

    Posts:
    2,055
    Likes Received:
    2,279
    Joined:
    Nov 2, 2003
    Location:
    Orange County, CA
    Yep, i use Chrome (always up to date) on an old Windows 7 box. Every now and then NFL links get redirected for me, but mostly they work fine. :shrug:

    I'll see what's on the Announcements and Support board and perhaps start a thread there. I've got a different annoying issue going on, too (using swype on Swiftkey keyboard on Android 10 results in doubled words). Apparently, this forum uses a "very old" version of Xenforo software. Maybe we can get to the bottom of this stuff!

    ...dave
     
    cardncubfan likes this.
  4. daves

    daves Keepin' it real! Contributor

    Posts:
    2,055
    Likes Received:
    2,279
    Joined:
    Nov 2, 2003
    Location:
    Orange County, CA
    As has been noted many times, most recently in the first two posts of this thread, links to pages on NFL.com are sometimes redirected to NFL Gamepass.

    Some people seem to be affected every time. As i posted earlier in that thread, the link worked fine for me. But then when i went back just now, i got redirected as well!

    Hopefully we can collect data on when this happens and when it doesn't, what browser, version, O/S, and other variables are at play, and get to the bottom of this!

    ...dave
     
    jf-08 likes this.
  5. Solar7

    Solar7 Also Skeptical

    Age:
    33
    Posts:
    7,914
    Likes Received:
    6,094
    Joined:
    May 18, 2002
    Location:
    Las Vegas, NV
  6. daves

    daves Keepin' it real! Contributor

    Posts:
    2,055
    Likes Received:
    2,279
    Joined:
    Nov 2, 2003
    Location:
    Orange County, CA
    Really interesting... both of those links worked correctly for me... but now the link in the first post in this thread, which worked for me earlier, is no redirecting me to Gamepass!

    BTW, i posted a thread about this issue in the Announcements and Support forum for this here.

    ...dave
     
  7. Solar7

    Solar7 Also Skeptical

    Age:
    33
    Posts:
    7,914
    Likes Received:
    6,094
    Joined:
    May 18, 2002
    Location:
    Las Vegas, NV
    I think I've isolated the issue.

    In the short term, for anyone who wants it to open in Chrome, you should be able to open the correct link by holding down the "alt" button and clicking on the link. What's functionally causing this, from what I can tell on my end, is that there's a definition between "Internal" and "External" links, related to the "target=_blank" parameter.

    More links I'm using for reference, please ignore: https://www.arizonasportsfans.com/f...g-completely-different-the-match-game.347901/

    https://www.azcardinals.com/news/kyler-murray-makes-25-000-donation-for-children-s-meals
     
    jf-08 likes this.
  8. daves

    daves Keepin' it real! Contributor

    Posts:
    2,055
    Likes Received:
    2,279
    Joined:
    Nov 2, 2003
    Location:
    Orange County, CA
    Seems peculiar, but perhaps the forum software doesn't add the "target=_blank" immediately, but updates links after some delay. Can't imagine any reason for that and haven't tested it.

    The link in the first post of the thread worked for me initially, but now redirects.

    And the two links you posted in post #10 above worked for me initially, but now redirect!

    All three now have the same html source:
    Code:
    <a href="http://www.nfl.com/news/story/0ap3000001108856/article/deandre-hopkinsinfused-cardinals-will-be-nfls-cinderella-team" target="_blank" class="externalLink" rel="nofollow">
    Holding down "Alt" while clicking does work for me.

    I'll try this as a test:
    http://www.nfl.com/news/story/0ap30...nfused-cardinals-will-be-nfls-cinderella-team

    Edit #1: (about 5 minutes after my original post) So much for that theory! Now i'm really baffled. The above link works for me, a few minutes after posting. But the html source appears EXACTLY the same as the above links that no longer work! I clicked the link, went directly to the story on NFL.com, hit <ctrl-U> to view the source, copy/pasted, and it's identical.

    So, are our Chrome browsers behaving differently when operating on the same source?! Or is NFL.com detecting multiple visits from the same referring URL, and eventually directing people to Gamepass? The latter seems more likely, but there should be plenty of evidence of this happening to others. Time to google!

    Edit #2: (about 10 minutes after my original post) I'm not seeing any evidence that this is happening to anyone outside of this forum! And, apparently this happens every time for some people... as far as i know, i'm the only one who gets correct behavior sometimes, for a while, then eventually get redirected. So that points back to something on the user side. Hmmmmm....

    Edit #3: (about 20 minutes after my original post) And now, just to really confuse things, all links on this page are working correctly - the one in the OP's post #1, both of the ones in @Solar's post #10, and the one above.

    ...dave
     
    Last edited: Apr 9, 2020
    Solar7 likes this.
  9. Solar7

    Solar7 Also Skeptical

    Age:
    33
    Posts:
    7,914
    Likes Received:
    6,094
    Joined:
    May 18, 2002
    Location:
    Las Vegas, NV
    So, I think I have it in the AdThrive header tag or Javascript implemented as a shell on the entire Xenforo structure that makes the installed scripts work. If you look at the top portion of the source, the content only equals Edge or Chrome, which would explain why it's working on Mozilla based environments.

    Using it on Safari, it redirects to vglink and pepperjam marketing before making it there, which makes me think that AdThrive has to be breaking it. My guess is that this happens in the CSS shell instead of HTML. In copying the URL in earlier moments, the rich text editor included more information around URLs to auto-link them. It's probably a plugin...

    Gonna make another post outside of rich text.
     
  10. daves

    daves Keepin' it real! Contributor

    Posts:
    2,055
    Likes Received:
    2,279
    Joined:
    Nov 2, 2003
    Location:
    Orange County, CA
    @Solar, once you start talking CSS you've surpassed my knowledge of web front-end software. Definitely seems as though you're onto something.

    Check my Edit #3 above: As of then, and now, ALL links on this page are working for me, without holding <alt>. Once again, i'm using Chrome (80.0.3987.163 and updating right now).

    It's bizarre that the behavior is intermittent!

    ...dave
     
  11. Solar7

    Solar7 Also Skeptical

    Age:
    33
    Posts:
    7,914
    Likes Received:
    6,094
    Joined:
    May 18, 2002
    Location:
    Las Vegas, NV
    I'm sure you know way more front end than I do - all I can do is point out potential problems! I'm in digital ad tech, so I just know some of the pathways.

    The biggest deal are the ad redirects that aren't seen on Chrome, and then analyzing the URLs once you make it to Gamepass:

    Code:
    https://gamepass.nfl.com/packages?campaign=sp-nc-gd-af-pj&affiliateId=43737&affiliateCustomId=k8tt20konc00xltj00due&affiliateCustomUrl=http%3A%2F%2Fwww.nfl.com%2Fnews%2Fstory%2F0ap3000001108856%2Farticle%2Fdeandre-hopkinsinfused-cardinals-will-be-nfls-cinderella-team&clickId=3063767762
    All of the affiliate jargon tells me that something ad related is going on, most likely connected to a plugin that tries to pass on the information about the affiliate code, individual user session, and then goes forward.

    @daves, by chance, are you a GamePass subscriber, maybe after it became free? That might invalidate the affiliate link and explain why it's working for you more often than not.

    I used to work in affiliate marketing, so this isn't uncommon. Most sites that link to a product have these codes so they make a certain percentage of the referral to the site.
     
  12. daves

    daves Keepin' it real! Contributor

    Posts:
    2,055
    Likes Received:
    2,279
    Joined:
    Nov 2, 2003
    Location:
    Orange County, CA
    Nope, on the occasions when i'm redirected, i just get taken to the signin page.

    At the moment, all links on this page are working properly for me (still / again).

    I am a paid subscriber to ASFN.

    I have the Adblocker plugin installed and enabled. Just disabled it and... all the links still work!

    ...dave

    P.S. Mods, feel free to move this part of the conversation to the relevant thread i created in the Announcements and Support forum!
     
    Last edited: Apr 10, 2020
  13. cardncubfan

    cardncubfan H

    Age:
    57
    Posts:
    7,819
    Likes Received:
    3,077
    Joined:
    Aug 7, 2008
    Location:
    Chandler
    If I use Alt then the links work, if not it redirects to Gamepass. I did sign up for free btw.
     
    Ronin likes this.
  14. GuernseyCard

    GuernseyCard Registered

    Posts:
    8,478
    Likes Received:
    3,988
    Joined:
    Dec 29, 2012
    Location:
    St. Helier, Jersey, Channel islands
    I tried it and it redirects me to my all-sports DAZN package where I already have All-Access.
     
  15. jf-08

    jf-08 Administrator; Rules Creator Staff Member

    Posts:
    15,800
    Likes Received:
    1,818
    Joined:
    May 15, 2002
    Location:
    Chandler
    Done and thank you.
     
    daves likes this.

Share This Page